Wet54g

From YobiWiki
Jump to: navigation, search

Contents

Intro

WET54G is a ethernet-wireless bridge.

I was a fan of the older WET11 but now that I use exclusively WPA on my network, I bought a WET54G.
WPA was designed to be able to replace WEP by WPA via simple firmware upgrade but if the vendor prefers to force you to buy a new product than to give you WPA for free via firmware upgrade...
If you wonder why I don't want to hear about WEP anymore, check my presentations in the Security Resources page.
This device supports WPA and WPA2 and exists since quite a while but curiously is quite hard to find.

Installation

Was a nightmare!

  • Not because I did it exclusively from Linux, without using the Windows wizard
  • Not because I had to find the static IP manually, it took me 20secs:
    • fping -g 192.168.0.0/23 -a 2>/dev/null
    • This gives 192.168.1.226
  • Not because I had to configure my wired interface on the laptop with an IP of the same range as my Wi-Fi network, also in 192.168.1.x, it's easy to deal with such situation:
    • ping -I eth0 192.168.1.226
    • route add -host 192.168.1.226 eth0
  • Not because I had to find the login/passwd, it took me 10secs:
    • admin/admin (very hard, I was used of admin without password...)
  • Not because I never managed to go back to the default settings with the reset button (with fw2.03, didn't try with fw2.07), no matter if I keep it pressed when booting or whatever, beware!
  • Not because the link to online doc from internal website was wrong, correct link being ftp://ftp.linksys.com/wet54gv2_ug.pdf (instead of wet54gv2-ug.pdf), anyway who thinks this doc could have helped me?
  • Not because the technical center of Linksys known only about WET54G v3.0 while I have a v3.1

But because a bug in the firmware caused the stuff to crash every time it authenticates with my WPA Wi-Fi network.
So to continue debugging the issue I had the choice between turning off my access-point which is my ADSL router or to put the WET54G in a metallic box to avoid it to find my network. I chose the latest solution.
I found a newer firmware on Linksys website and flashed the stuff (upgrade link is on help page -> http://192.168.1.226/upgrade.asp)
So I upgraded from fw 2.03 to 2.07 even if there was nothing convincing me in the changelog.

Conclusions

After firmware upgrade, tadaaam, it worked smoothly, pfiiiiut!
But...

  • Why the changelog does not mention the fix of a such critical bug?
  • fw 2.07 was released a year ago, and fw 2.03 a month and a half before, how does it come that new products still come with older firmware?? I bought it online, so very few chances this was a device laying around for more than a year.
  • Side note: three days before, I returned a WPS54G (printer server) because it gave me some very similar problems, 3 pings and then nothing anymore till next reboot, seems it crashed repetitively.
    Probably the same Wi-Fi/WPA bug but I was less patient and gave up, returning the device to the shop.

Wet11

default config:

  • essid: linksys
  • mode: managed
  • IP: 192.168.1.225
  • L/P: admin/admin

Firmware updates: http://www.linksys.com/download/firmware.asp?fwid=170

Personal tools
Namespaces

Variants
Actions
Navigation
Tools